AnyLogic Preferences

Preferences dialog box allows you to change AnyLogic preferences.

 To open AnyLogic Preferences dialog box
  1. Choose Tools > Preferences... from the main menu.
The dialog contains eight pages:

General page

The General page contains controls for setting up general AnyLogic preferences:


Show welcome page on startup - If selected, the Welcome page will be shown every time you start AnyLogic.

Notify about AnyLogic updates - If selected, you will be notified about new updates of AnyLogic. In the case you have valid Support Services, you will be able to download new releases from the web site. 

Show new survey/feedback invitations - If selected, checks whether there is a new online survey to fill and prompts the user to the survey, if any.

The number of recently opened models in the File menu - Here you can define the maximum number of shortcuts to recently opened models that will be present in the File > Recently Opened Models submenu.

Default model location - Here you select the folder that will serve as a default location when creating a model or saving it with a new name.

Enable autosave - If selected, all AnyLogic models currently opened in the workspace will be automatically saved in the background when the defined interval (set in the Autosave interval box) will elapse from the moment of the last save. You can find more information on automatic backup and recovery of AnyLogic models here.

Language - AnyLogic UI is currently localized into English, Russian, German, ChineseSpanish and Portuguese (Brasil). When you start AnyLogic, it chooses the localization language according to the locale settings of your operating system (if AnyLogic is not localized for the particular user's locale, English is used). Here you can change the language of AnyLogic if you want to use another language. 


Development page

The Development page contains the preferences that define development details of models and libraries.


Preview rename results - If selected, every time the user will rename some model element(s) using the Refactor > Rename command, the Rename results preview dialog showing all possible rename results will be displayed.

Show tooltips in Palette and Properties - If selected, when you hover the mouse over some element name in the Palette and Properies, a tooltip showing the element descriptlion is shown.

Show line numbers - If selected, the line numbers are shown in Java editor.

Library developer mode - If selected, unhides the specific properties that may be useful only if you develop custom libraries. Please refer here for details.

Create datasets for dynamic variables - Defines the default value of the Create datasets for dynamic variables option for all new agent types the user will create (you can find this option in the Advanced section of the agent type's properties, more details here).

Hide Problems view when there are no errors - If selected, the Problems view will hide automatically when models do not contain any errors, otherwise the view visibility will be controlled solely by user.

Hide Console view when model run is finished If selected, the Console view will hide automatically when model run is finished, otherwise the view visibility will be controlled solely by user.

Continue launch if project contains errors - The group of buttons defining whether AnyLogic will continue launch if a project contains errors.

Always - a project will be launched anyway.

Prompt - the message box will be shown informing about the errors and providing an ability to cancel launch or continue anyway.


Graphical editor page

The Graphical editor page of AnyLogic preferences contains settings related to the graphical editor.

Flowchart block connection - The section of preferences that defines rules for drawing flowcharts in the graphical editor.

Connect automatically, when ports are close enough - If this option is selected, the connectors between library objects that you drop onto the agent diagram will be drawn automatically if the distance between them is less than 70 pixels.

Enable drawing connectors by single-clicking - This option is not selected by default. Select it if you want to start drawing connectors with one click.

Delete hanging connector when deleting flowchart block - This option may be useful when you do not want to delete connectors that you do not need anymore, and the new library objects, which you might want to add instead of deleted ones, connect automatically.

Change agent scale on adding specific space markup elements (roads, rails) - Here you define whether AnyLogic will propose the user to change the agent scale on adding rail- or road-related space markup shapes on its graphical diagram. 

Auto-resize 3D objects to match agent scaleHere you define whether AnyLogic will automatically resize 3D objects that you add on the agent's graphical diagram to make them correspond to the current agent scale (e.g., scale houses to correspond to railways drawn on the canvas). Note that this setting affects only the newly added 3D objects and does not affect the 3D objects already present on the graphical diagram.


Connection page

The Connection page enables to set up connection settings. If you use a proxy, select the Use Proxy check box and define the settings in the Http proxy and Port edit boxes. If required, specify Login and Password. If you use team license, you can activate AnyLogic here in AnyLogic License Server section.

If you use a proxy to access internet (e.g. a GIS map server), but you also need to bypass a proxy to connect to a local server (e.g. a database server), you can type the local server name in the Do not use proxy for addresses beginning with list (see the figure below). You can list several URLs here separated by semicolons.



Key combinations page

The Key combinations page enables you to change the shortcut keys for the commands. The table on the page lists commands and shortcut keys assigned to them.
Currently it allows to change the key combination for code completion.


 To set a new shortcut for a command

  1. Select the row holding a required command in the table.
  2. Click in the Key Sequence cell and press the keys combination that you want to use as a shortcut key.

Runtime page

The Runtime preferences page allows you define a model run-time behaviour.


Show counters at flowchart blocks - If selected, the counters will be shown near libraries's block icons (displaying the number of agents inside the block, the number of agents entered the block, etc.), see the figure below.

Animate ports of flowchart blocks - If selected, the states of the flowchart block ports will be animated at model runtime. If there are some agents pending at the port, the port will be highlighted with dark orange, as shown on the figure below.

Number of processors for parallel execution - AnyLogic supports multicore processors. When you start an optimization or a parameter variation experiment, AnyLogic may run several iterations in parallel on different processor cores. Thereby performance is multiply increased and the experiment is performed significantly faster than on single core processor. If your machine has a multicore processor, here you can set the number of processors to be used for parallel execution of model runs by AnyLogic.


Database page

On the Database page you can tune the settings related to the built-in AnyLogic database.

Show warnings about data loss - If selected, the user will see warnings about data loss.

Show warnings about potential data loss - If selected, the user will see warnings about potential data loss.

Show database questions - If selected, the user will see questions generated by the database.

Show hidden ID column "al_id" - If selected, the hidden column al_id will be visible in the table editor. This column contains unique identifiers for the table records.

Remove the model log before commiting to SVN repositoryIf you use SVN and commit your models to it, this option allows to choose whether the model log should be commited along with the model or not.

Connection timeoutHere you define the timeout for connection to the database (in seconds).


Advanced page

The Advanced page of AnyLogic preferences contains additional AnyLogic settings.


Show memory heap status (Restart application to apply option) - If selected, the heap status will be shown in the AnyLogic status bar (this option requires restarting AnyLogic to be applied).

Enable AnyLogic light and grid shaders - If selected, AnyLogic will use light and grid shaders, providing nice lighting effects. Please note that shaders may be not supported by some X3D files and/or hardware.

Run button (F5) - The option sets the default behavior of the  Run button, which you can find the on the AnyLogic toolbar. You can select which type of the model should be run when you click this button or press F5 on your keyboardLaunches the model just created / opened or Launches the previously run experiment.
Note that you can click the arrow next to the  Run button on the AnyLogic toolbar to explicitly select the experiment you want to run.