AnyLogic menu

AnyLogic main menu consists of the following menus:

File menu

The File menu contains commands for performing the basic operations with model files in AnyLogic.

New - Creates new AnyLogic element. Type of the element is selected from the submenu: it can be either Model, Agent Type, Option List, Java Class, Java Interface, Dimension, Experiment, or Library.

Open - Opens existing AnyLogic model.

Recently Opened Models - Allows to open a model from the list of recently opened models. The maximum number of models in the list is defined in AnyLogic preferences.

Save - Saves all changes you have done in the currently selected model.

Save As... - Saves the currently selected model with a new name.

Save All - Saves all models currently present in the workspace.

Close - Closes the currently selected model.

Close Others - Closes all opened models except for currently selected one.

Close All - Closes all models currently opened in the workspace.

Import

From Vensim - Imports Vensim model into AnyLogic.

Export

To AnyLogic Cloud - Exports the currently selected model to AnyLogic cloud.

To Stand-alone Java Application - Exports the currently selected model as standalone Java application.

SVN - Contains commands for team development with SVN.

Checkout... - imports the model fromSVN repository.

Share... - adds the selected model to theSVN repository.

Commit... - commits the local changes to the SVN repository.

Update - updates the local working copy of the model with the model from the SVN repository.

Exit - Exits AnyLogic.

Edit menu

The Edit menu contains commands that are frequently needed when you edit your model.

Undo - Cancels the previously performed action.
Redo - Performs the previously cancelled action.
Cut - Cuts the current selection.
Copy - Copies the current selection.
Copy as Image - Copies the image of the selection.
Paste - Pastes the ClipBoard contents.
Delete - Deletes the current selection.
Select All - Selects all in the currently opened editor.
Search/Replace... - Searchs through the workspace for the specified text stringsand optionally performs replacements of these strings by another ones.

View menu

The View menu contains commands for managing the set of views currently opened in AnyLogic workspace.

Projects - Opens/closes the Projects view.

Properties - Opens/closes the Properties view.

Palette - Opens/closes the Paletteview.

Console - Opens/closes the Consoleview.

Problems - Opens/closes the Problemsview.

Search - Opens/closes the Searchview.

GIS Search Results - Opens/closes the GIS Search Resultsview.

Debug - Opens/closes the Debugview. *

Breakpoints - Opens/closes the Breakpoints view. *

Variables - Opens/closes the Variables view. *

Expressions - Opens/closes the Expressions view. *

Log - Opens/closes the Log view.

* This view is available only in AnyLogic Professional and AnyLogic University Researcher edition.

Draw menu

The Draw menu contains commands that are used when you work in the graphical editor. The menu commands are available only when the current graphical editor is open.

Order - Contains commands that allow you to change the Z-order of the currently selected shape:
Bring to Front - Places the shape on top of all other shapes.
Bring Forward - Moves the shape one step up (swaps it with the shape directly in front).
Send Backward - Moves the shape one step down.
Send to Back - Places the shape below all other shapes.
Grouping - Contains commands for grouping/ungrouping shapes:
Ungroup - Ungroups all the shapes from the group that contains the currently selected shape.
Select Group Contents - Selects all the shapes of the group that contains the currently selected shape.
Create a Group - Creates a new group and adds all currently selected shapes to this group.
Add to Existing Group - Adds the currently selected shapes to one of already existing groups (you will need to choose the group where you want to add shapes by clicking its icon in the graphical editor right after invoking this command).
Remove from group - Removes the currently selected shape from the group.
Zoom - Contains commands for zooming the graphical editor diagram:
Zoom to 100% - Zooms the contents of the graphical editor to the original zoom (100 %).
Zoom Out - Zooms out the contents of the graphical editor.
Zoom In - Zooms in the contents of the graphical editor.
Grid - Contains commands for controlling the diagram grid:
Enable/Disable Grid - Turns binding to the grid on/off.
Show/Hide Grid - Turns the grid visibility on/off.
Show/Hide Axes - Turns the coordinate axes visibility on/off.
Align - Contains commands for aligning elements in the graphical editor:
Horizontal Align Left - Aligns left borders of all selected elements to the left border of the leftmost element.
Horizontal Align Center - Shifts all the selected elements horizontally so that their centers lie on the vertical axis that goes through the center of the selected area.
Horizontal Align Right - Aligns right borders of all selected elements to the right border of the rightmost element.
Vertical Align Top - Aligns top borders of all selected elements to the top border of the topmost element.
Vertical Align Center - Shifts all the selected elements vertically so that their centers lie on the horizontal axis that goes through the center of the selected area.
Vertical Align Bottom - Aligns bottom borders of all selected elements to the bottom border of the bottommost element.

Hide - Contains commands for hiding/unhiding shapes of the same type in the graphical editor. When hidden, shapes become half-transparent, and user cannot select them.

Hide Space Markup Elements - HidesUnhides all space markup elements on the current graphical diagram.
Hide Shapes - Hides/Unhides all presentation shapes on the current graphical diagram.
Hide SD Links - Hides/Unhides all System Dynamics links on the current graphical diagram.
Hide 2D Elements - Hides/Unhides 2D shapes (all elements with the Advanced property Show in set to 2D only).
Hide 3D Elements - Hides/Unhides all 3D shapes (all shapes with the Advanced property Show in set to either 2D and 3D, or 3D only).

Model menu

The Model menu contains general commands for working with your models.

Build -Builds the currently selected model.
Run - Runs the experiment chosen from the popup menu.
Debug - * Starts debugging the experiment chosen from the popup menu.
Resume -* Debug command. The thread resumes its execution and stack frames are no longer displayed for the thread.
Step Over - * Debug command. The currently selected line is executed and suspends on the next executable line.
Step Into - * Debug command. The next expression on the currently selected line to be executed is invoked, and execution suspends at the next executable line in the function that is invoked.
Step Return - * Debug command. Execution resumes until the next return statement in the current function is executed, and execution suspends on the next executable line.
Stop - Terminates the currently running model.
* Available only in AnyLogic Professional and AnyLogic University Researcher edition,while debugging the model.

Tools menu

Create Documentation... - Opens the Create Model Documentation dialog that prompts to create documentation on the selected model. All widespread formats are supported: PDF, DOCX, HTML. The document will contain a list of all model elements along with their properties, descriptions, and optional screenshots. Elements are logically grouped by categories (system dynamics stock-and-flow diagrams, statecharts, etc.).

Check for Snapshot Compatibility - Checks, whether the currently selected model satisfies snapshot requirements. If yes, you can save and restore model snaphots, i.e. save the full state of a model during runtime to a file, and restore it at a later time and continue running simulation from the saved moment of simulation.

Check System Dynamics Units - Checks consistency of units in the selected model. If no model is selected, checks system dynamics units in all models currently opened in the workspace.

Reset Perspective - Resets the current layout of AnyLogic views, editors, and toolbars to the default one. This command may be helpful in case the user has occasionally arranged views in an inconvenient way and wants to return back to the default layout settings (when the Projects view is docked to the left side of the application window, the Palette view - to the right one, the Properties - to the bottom, etc.).

Preferences... -Opens AnyLogic preferences dialog box allowing user to change AnyLogic preferences.

Help menu

The Help menu contains commands providing access to help information, AnyLogic Support Team and AnyLogic activation wizard.

AnyLogic Help - Opens AnyLogic Help documentation in a standalone Help window.

Welcome - Opens AnyLogic Welcome page.

Example Models - Opens the Example Models tab of the Welcome page. It provides the user with links to all example models distributed along with AnyLogic.

Changes History - Opens the text file listing history of changes.

Get Support... - * Opens AnyLogic Support dialog box allowing to ask a question or send a feedback to AnyLogic Support Team.

Anylogic Users on LinkedIn - ** Opens the LinkedIn Anylogic Users community page in the user's default browser. Instead of the support services offered to the AnyLogic commercial users, PLE users can alternatively get support from our LinkedIn group users.

Training Courses... - Opens the web page listing the information about the training courses provided by The AnyLogic Company.

Renew Maintenance and Support... - * Enables to renew the license on AnyLogic maintenance and technical support. Opens the page in your default web browser that lists the information on the cost of the renewal and provides the form for purchasing the license.

Update Dongle... - * Opens the dialog allowing to update activation dongle with the update file containing updated information about the Maintenance and Support Service license. Use this option when your AnyLogic is activated using USB dongle and you renew your Maintenance and Support Service.

Check for Updates - * Connects to The AnyLogic Company web site and checks whether new AnyLogic updates are available.

Activate Product... - * Opens the activation wizard prompting activation of the product.

Terms of use - Opens a document in the user's default browser with the software license agreement terms.

About AnyLogic - Displays information about AnyLogic: license type, version number, product expiration date, Support Services status, etc.

* Available only in AnyLogic Professional and AnyLogic University Researcher editions.

** Available only in AnyLogic PLE edition.