Private Cloud: System requirements

Note: Cloud Lite was tested on Ubuntu 18.04 LTS. We recommend using the current Ubuntu LTS distribution for full compatibility.

Make sure your host machine has the Docker package installed. To do it, run the following command in your Linux terminal:

sudo docker ps

If this command returns no errors, you can proceed.

To learn how to install Docker, see the official manual.

The requirements listed above are minimal. The desired configuration depends on the intended cloud usage (types of models that will be run on the cloud).

When considering a choice of CPU, please keep in mind that 3 cores are required for non-execution activities. It means that the number of simultaneously executed models is three less than the number of available cores on the machine (for example, a 4-core CPU will only be able to run one model at a time). It is recommended to pick an appropriate number of cores, depending on your workload.

Keep in mind that the Lite version has a limit of 16 models running concurrently, that is, any cores aiming to exceed this limit will not be utilized.

Should you decide to install AnyLogic Private Cloud Lite on the RedHat OS machine, please keep in mind that certain commands will differ from those described in this guide. For example, instead of the Ubuntu command sudo apt install, you will need to use sudo yum install.


Related topics

AnyLogic Private Cloud

AnyLogic Cloud

AnyLogic Cloud options